22.02.2020, 03:33 UhrDeutsch | English
Hallo Gast [ Registrierung | Anmelden ]

Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
Autor Nachricht
*michi*
Titel: AppImage Programme laufen nicht mehr  BeitragVerfasst am: 05.02.2020, 21:36 Uhr



Anmeldung: 15. Apr 2005
Beiträge: 125
Wohnort: Karlsruhe
Hallo,

ich habe ein schön älteres Kanotix am rennen:
Code:
infobash -v3
Host/Kernel/OS  "pandora" running Linux 3.18.0-6-generic x86_64 [ Kanotix Spitfire-nightly Spitfire64 141216a KDE-special ]
CPU Info        (1) Intel Core2 Duo T9600 @ 6144 KB cache flags ( sse sse2 nx lm pni vmx ) clocked at [ 1600.000 MHz ]
                (2) Intel Core2 Duo T9600 @ 6144 KB cache flags( sse sse2 nx lm pni vmx ) clocked at [ 2801.000 MHz ]
Videocard       NVIDIA GT216M [GeForce GT 240M]  X.Org 1.16.4  [ 1600x900 ]
Network cards   Qualcomm Atheros AR8131 Gigabit Ethernet, at port: ec00
                Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express)
Processes 212 | Uptime 1:53 | Memory 885.4/3952.1MB | HDD ATA Samsung SSD 840,ATA SAMSUNG HN-M101M Size 1500GB (64%used) | GLX Renderer GeForce GT 240M/PCIe/SSE2 | GLX Version 3.3.0 NVIDIA 340.106 | Client Shell | Infobash v2.67.2

Seit geraumer Zeit kann ich keine AppImages mehr starten (z.B. Nextcloud Client und GoldenCheetah):

Code:
miri@pandora:~$ ./GoldenCheetah_v3.5_amd64_Linux.AppImage
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./GoldenCheetah_v3.5_amd64_Linux.AppImage)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libkmldom.so.1)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libkmlbase.so.1)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5Svg.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5WebEngineWidgets.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5OpenGL.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5Charts.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5Widgets.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5Multimedia.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5WebEngineCore.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5Gui.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5Xml.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5Sql.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5WebChannel.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5Network.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5Concurrent.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5SerialPort.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5Bluetooth.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5Core.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5Quick.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5PrintSupport.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5QuickWidgets.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5Positioning.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libsnappy.so.1)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5Qml.so.5)
./GoldenCheetah_v3.5_amd64_Linux.AppImage: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /tmp/.mount_GoldeniaZ3Ei/lib/libQt5DBus.so.5)


Komme ich um eine Neuinstallation meines betagten Kanotix rum?

*michi*
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Kano
Titel: AppImage Programme laufen nicht mehr  BeitragVerfasst am: 06.02.2020, 19:07 Uhr



Anmeldung: 17. Dez 2003
Beiträge: 16709

Dann wär es mal Zeit auf Silverfire umzusteigen. Wenn man sich sehr gut auskennt könnte man auch über dist-upgrade umsteigen, aber das Special ISO als quelle ist etwas trickreicher als ein normales. Ich könnte es schon, aber das zu erklären dauert länger.

Hast du /home von / getrennt? Manchmal ist eine Variante die, man konvertiert die / Partition zu einer /home (alles bis auf lost-found löschen und den Inhalt von /home auf / verschieben im Live Mode) und verkleinert diese Partition um 25 GB, erstellt ne neue und bindet die konvertierte als /home ein.
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
*michi*
Titel:   BeitragVerfasst am: 16.02.2020, 19:19 Uhr



Anmeldung: 15. Apr 2005
Beiträge: 125
Wohnort: Karlsruhe
Hi Kano,
ja ich habe eine eigene /home partition.
Ich habe immer recht viel Mühe alle Pakete wieder zu installieren. Bin kein apt oder dpkg Profi Smilie
Deine Methode muss ich nochmal geistig durchdringen
Thx
*michi*
 
 Benutzer-Profile anzeigen Private Nachricht senden  
Antworten mit Zitat Nach oben
Beiträge vom vorherigen Thema anzeigen:     
Gehe zu:  
Alle Zeiten sind GMT + 1 Stunde
Neues Thema eröffnen   Neue Antwort erstellen
Vorheriges Thema anzeigen Druckerfreundliche Version Einloggen, um private Nachrichten zu lesen Nächstes Thema anzeigen
PNphpBB2 © 2003-2007 
 
Deutsch | English
Logos and trademarks are the property of their respective owners, comments are property of their posters, the rest is © 2004 - 2006 by Jörg Schirottke (Kano).
Consult Impressum and Legal Terms for details. Kanotix is Free Software released under the GNU/GPL license.
This CMS is powered by PostNuke, all themes used at this site are released under the GNU/GPL license. designed and hosted by w3you. Our web server is running on Kanotix64-2006.